Trouble need help!!
Subaru WRX Forums - Powered by vBulletin
Results 1 to 4 of 4
  1. #1
    0bhp 3G Impreza CSwope's Avatar
    Join Date
    Oct 2015
    Posts
    2
    Rep Power
    0

    Trouble need help!!

    I have a 2013 wrx limited and when i started in this morning the check engine light was on along with the traction control light and the cruise light was flashing. It is running fine but wont let me set the cruise any ideas what might be causing this thanks in advance for any help !!!

  2. #2
    0bhp 3G Impreza Boostrex2010's Avatar
    Join Date
    Nov 2016
    Posts
    2
    Rep Power
    0
    I bought a base model 2010 sedan and the same thing happened to me I've read the code and it said it was an 02 sensor I just need to know which one it it's on my car being's I've yet to jack it up and look but all the parts stores I went to have the part numbers all mixed up and my car has an exhaust intake and idk what else the dealer I bought it from wouldn't let me see the intake paperwork and I've already had the master cylinder fail but keep me updated on what you find out

  3. #3
    0bhp 3G Impreza R_watters_32's Avatar
    Join Date
    Sep 2019
    Posts
    1
    Rep Power
    0
    Same issue here. Just bought a ‘14 WRX wagon. The check engine light, flashing cruise control light and TC light all came on at once. It’s not making any noise or performing differently.

  4. Remove Advertisements
    WRXForums.com
    Advertisements
     

  5. #4
    0bhp 3G Impreza narenravi88's Avatar
    Join Date
    Sep 2019
    Posts
    1
    Rep Power
    0
    I have 2013 WRX Wagon. I had to speed up a hill on the highway, I shifted down and hit the accelerator real hard... The car jerked forward and the check engine light, flashing cruise control and traction control light came ON. I checked the code and it threw a P0244 - Waste gate solenoid code. I reset the light and it hasn't come ON for over 120 miles now. However, my turbo is totally off. I am not seeing any boost even at 5500 RPM. Anybody have any suggestions about this?

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. AP/Manager Trouble
    By TwentyDollarBil in forum Subaru WRX General Aftermarket Talk
    Replies: 5
    Last Post: 11-12-2009, 06:35 PM
  2. stage 2 trouble
    By 08wrxsubie in forum 3G WRX Chat
    Replies: 19
    Last Post: 09-22-2009, 03:10 PM
  3. Replies: 3
    Last Post: 07-21-2009, 08:11 PM

Tags for this Thread