Subaru WRX Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1 (Edited)
Alright, so I recently went stage 2. (Perrin Downpipe, AEM Intake, Invidia Q300 Catback)

I put on an opensource tune, the original tune I had (Not TP) Caused the car to overboost, throwing the P0244 (Turbo Wastegate Out of Operating Range). First time this happened it popped the hose from the throttle body to the intercooler off. So I pulled my intercooler, removed the hose, removed those little end caps, replaced the water clamps with T-bolt clamps, and put it all back together, did another run, car overboosted again. So I decided to get rid of that crappy tune and got a tune from Eric at torqued performance.

I haven't sent Eric revisions yet, but will be this week.

Basically, I get on the gas full on through 1st and 2nd gear and it is fine, however when I reach third and get to max boost I hear a squeal. It's loud. I checked my intercooler hose again and it is fine, on both ends. Checked my bypass valve seal, checked my turbo to intercooler seal as well, all were fine.

This isn't my video's, but they make the same exact sound:


The sound goes away after 1-2 good pulls...

Anybody have any ideas?
 

·
Registered
Joined
·
899 Posts
Idk sounds like a leak to me, happened to me but I am on the FMS TMIC, throttle body hose popped off eventually.
 

·
Registered
Joined
·
160 Posts
Discussion Starter #3
Idk sounds like a leak to me, happened to me but I am on the FMS TMIC, throttle body hose popped off eventually.
Yeah, my hose had popped off like I said, but I put it back on and it's stayed there since....I'm out of ideas of where to look...
 

·
Registered
Joined
·
160 Posts
Discussion Starter #6
+1...that would seem like the obvious solution, wouldn't it? ;)

when you say you "checked" those various areas, does that mean you did a boost leak test, you sprayed soapy water, what did you actually do thus far?
As far as the TB hose I visually checked it to make sure it was on, put some soapy water around my BPV, and around the turbo outlet. No bubbles there, but I can't really test it here. I'll run to the dealer and see if they can do a boost leak test after work.
 

·
Registered
Joined
·
332 Posts
leak somewhere, tb or bpv
 

·
Registered
Joined
·
160 Posts
Discussion Starter #10
this...

did you ever test for boost leak?
Haven't had a chance to make it to my buddy's garage, and I really have no way to do it at my apartment complex, but i'm guessing it's the BPV, because the TBH is on there TIGHT and hasn't budged, no tears or anything.
 

·
Registered
Joined
·
162 Posts
I just went stage 2 and am experiencing the EXACT same sound, I asked Eric @ TP about it and he said that's just the sound of the turbo running close to the surge line. Would be interested to see results if you did a boost leak test, though.
 

·
Registered
Joined
·
332 Posts
What gear are you in when you are doing the pull?
 

·
Registered
Joined
·
1 Posts
I know this thread is a few months old, but I'm interested in the outcome if the OP has any yet? I recently went with a TP stage 2 on my '13 WRX HB and have this same noise. It is mostly there at highway speeds, and really comes out at high boost in lower rpm range, such as 5th gear going 50 mph.

Eric said the exact same thing to me. He said that the squealing noise was normal for VF series turbos and in the taller gears, boost runs close to the surgeline. The solution - to avoid WOT under 3000 rpm.

I'm going to check all my connections and do a boost leak check. If this doesn't solve anything, I may go down to an 18psi boost map and see what happens. My map is giving me 19psi consistently, but the needle gets to 20psi initially.
 
1 - 18 of 18 Posts
Top