Subaru WRX Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
so ive finally installed my rallitek sways and avo front endlink+rallitek rears.

im getting this low clunk noise from the rear. a friend of mine went on a ride with me and said that this is could probably mean that something is a bit loose? im very sure ive tightned everything down....


any help would be awesome. thanks!
 

·
Registered
Joined
·
629 Posts
I'm getting the exact same thing....I don't think anything is loose. I put the car on a rack and double checked everything, nothing was wrong. Hmmmmm........it's a mystery noise. I don't think it's anything to worry about.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #3
lol not anything to worry about?? sigh....


i'll guess i'll just have to recheck everything again.

... at least im not the only person?
 

·
Registered
Joined
·
169 Posts
I was getting a clunking noise from the rear, I needed to tighten down the nuts attached to the rear endlinks more thoroughly (BTW, I'm using the stock rear endlinks). Noise was gone after that. Now I'm getting a clunking noise in the front, I was just about to crawl under the car and make sure everything is tight, again...
 

·
Registered
Joined
·
629 Posts
I'm gonna look at the car again tomorrow and go over everything once again. I installed the RalliTEK rear endlinks and thought that would take care of it but no........I think it may be the bushings??
 

·
Registered
Joined
·
125 Posts
Discussion Starter #6
okkkay soo i WAS hearing the noise from the front, check it out, tested it fine.


now, it has all of a sudden disappeared. i dont hear a thing ???
 

·
Registered
Joined
·
125 Posts
Discussion Starter #7
i take it back... i hear it again :-\
 

·
Registered
Joined
·
1,802 Posts
Sometimes get a low clunk noise also, usually only if my car has been sitting for a while (at work, I back into my spot, in a store parking lot) I read somewhere (I think it was NASOIC) that it was the brake pads sliding forward when the car starts to move.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #9
i'm pretty sure i know why i hear that clunk on some turns. long story short, i used the original front bracket/bushings for the rear when i shouldve used the rear ones that came with it.
i'm gonna change it once it stops raining... it's been raining for almost a week now
 

·
Registered
Joined
·
125 Posts
Discussion Starter #10
0000018170 said:
i'm pretty sure i know why i hear that clunk on some turns. long story short, i used the original front bracket/bushings for the rear when i shouldve used the rear ones that came with it.
i'm gonna change it once it stops raining... it's been raining for almost a week now
sounds like a likely cause. there were a lot of people on v6performance.net who upgraded their accord with TL suspension components. A couple of them were send the wrong size bushings (bushings for a 20mm bar instead of a 17mm bar) and they experienced some clunking like you are describing. Do let us know if changing the bushings and brackets helps out the clunk as I am interested in the rallitek bars.
will do.
 

·
Registered
Joined
·
109 Posts
I posted this in another thread, but for what it's worth, try folding your rear seats down and see if the noise goes away.

After 2k miles or so, the striker for retaining the seat backs moved up a bit causing the seat latch to clunk against the striker. Since the striker is attached to the body, it sounds similar to a loose suspension (characterized by a low, clunking).

Worth checking out, especially if you've inspected the suspension and couldn't find anything.
 
1 - 11 of 11 Posts
Top