Subaru WRX Forums banner

1 - 20 of 565 Posts

·
Registered
Joined
·
2,678 Posts
Discussion Starter #1
Soo for the last few months I've had a squeak coming from my clutch pedal, and it's been driving me CRAZY!!! First, I tried lubricating the linkage on several different occasions... Nothing! I figured it must have been coming from a bushing somewhere by the clutch pedal, but I can't trace exactly where it's coming from!! I know it's not the clutch or throw out bearing, because the noise isn't coming from the transmission itself, but you can hear it from the engine compartment by the slave cylinder. Today, I finally got around to bringing it in to get checked out under warranty... I'm lucky to have gone to a cool dealership where they overlooked my stage II mods, and checked it out! They couldn't find a noise, so they are having a Subaru rep come to check it out tomorrow! Apparently there's a known problem, where the clutch pedal assembly separates from the firewall causes squeak every time the pedal is pushed in... Sounds like if that's the problem, it's gonna be a major pain in the ass to fix!! I just wanted to keep everyone posted on the problem in case anyone else has this problem, or maybe they will have it happen to then down the road.. I'll post whatever happens when I get a call tomorrow from the dealer.. For now, I'll keep rockin the Hyundai elantra rental car haha
 

·
Registered
Joined
·
209 Posts
I had this same issue, but I never thought it would be that big of a problem. I just assumed that it was something that needed to be lubed. I've kind of ignored it for a while.
 

·
Registered
Joined
·
2,678 Posts
Discussion Starter #3
It was just annoying me soo much and I'm getting close to my warranty expireing... So I figured I'd get it looked at while I still can lol
 

·
Registered
Joined
·
925 Posts
i got the same issue.. annoying.. i also have a brake pedal click.
 

·
Registered
Joined
·
328 Posts
I have the same problem and it drives me crazy too. I had it checked out by a local shop and the guy played around with it for a while. The guy ended up telling me that everytime I pushed the clutch all the in the entire steering column hooked up to the firewall would shift causing the noise. He said he couldn't do anything about so I'll prolly just take it to the dealer when I get my clutch fixed.
 

·
Registered
Joined
·
2,472 Posts
i remember hearing of this problem before and the dealership found a crack in the firewall. the guy posted up pics to show the crack on an old thread on this forum here somewhere. i am gonna pull back the carpet on my car when i get home from work to inspect mine. i don't have a squeak going on but i want to have a look for myself. might be the source of the noise. :)
 

·
Premium Member
Joined
·
3,839 Posts
Hmmmm... I thought it was just in the play in the pedal itself. Had it on the original clutch and this second clutch as well.. On mine, it sounds like it's just squeaking when I begin to depress the pedal, right as I initially press down. It doesn't squeak the entire way down, it sounds like it's only in the first 5% of the pedal push.

Very interested to see what this turns out to be!
 

·
Registered
Joined
·
2,678 Posts
Discussion Starter #8
My squeak comes when the pedal is at the end of its travel, right before it bottoms out. And while you have it bottomed out, it you release a little pressure and then re-apply the pressure repeatedly, its the best way to make the noise happen. I'm anxious for the phone call today, I cant stand not having my car!!!
 

·
Registered
Joined
·
2,678 Posts
Discussion Starter #9
Wow, So I got the call from subaru like 10 minutes ago... Exactly what I was scared of... They need the car for 2 weeks, and it looks like they have to rip the dashboard out. I hope I get my car back in the same condition as I dropped it off, only without the squeaky pedal. I worked as a tech at Ford for 3+ years and as a tech at Nissan for 2+ years, and i've seen my fair share of warranty hack jobs. They work on warranty jobs wrecklessly since they dont get paid well for warranty jobs. Ugh this is just really making me nervous and it really irk's me that a stupid little clutch pedal could be such a major problem. I am however, glad i'm getting it looked at NOW, rather then when it was out of warranty... This could have costed some MAJOR moolah if you have to pay for it out of pocket... Looks like I better get used to this damn Hyundai...

Moral of the story... Those of you that have this concern.. Get it checked out while you can still get it covered under warranty, and plan on not having your car for a week or 2 if the problem is the same as mine. This 2 weeks is gonna kill me.....
 

·
Registered
Joined
·
2,678 Posts
Discussion Starter #11
I have the clutch squeak too when I put the pedal in. It seems to only make the squeak when the engine is cold.
Yeah thats how mine started and it only got progressively worse. Also, when I first noticed the squeak it only happened when it was raining. It eventually got to the point that it happened when it was not raining. Then I noticed the noise sounded quieter when it was raining (oddly enough) lol
 

·
Registered
Joined
·
406 Posts
I have squeak and when the car is in neutral and I push the clutch in halfway sounds like a very light scraping tick noise
 

·
Registered
Joined
·
2,678 Posts
Discussion Starter #16
Ok guys... Lots more info on this problem..

Subaru dealership called back today. They currently have 3 Engineer's from JAPAN looking at my car...

Yes thats right!!!!

- Engineer's
- From Japan
- MY CAR

If I knew they were coming to look at my car, I would have told them to bring some JDM hottness with them!!!! ;D

Lol It's pretty crazy that these guys came from Japan just to look at my car. They asked me a couple questions about my driving habbits, and are trying to determine what is causing the weld's to break. They did verify at least 1 broken weld where the clutch pedal assembley meets the firewall, so they are waiting on an OK from the engineer's to go ahead and re-weld the broken welds.

They also found a squeak coming from the throw out bearing.. So they are installing a new clutch/TOB as well!!! I'm excited about the new clutch, because I have 28,000 miles on the car, and just knowing that i'll be starting out on a fresh clutch puts an ease on my brain.. Just one less thing i'll have to worry about.

Just wanted to give you guys a heads up.. And they said my car should be done by mid to late next week.. I'll be keeping my fingers crossed.. I miss my car!! Lol
 

·
Registered
Joined
·
57 Posts
Interesting... I have a definite "click" when I push my clutch in (08 STi), but it's very near to the top of the pedal. Most times I can ignore it, but sometimes it's horrendously irritating... Doesn't sound exactly like this problem, but maybe I'll bring it in...
 

·
Registered
Joined
·
1,861 Posts
another +1 to this. Happened a couple times on rainy days and randomly when ambient temp is less than 70 deg F. On a cold start. Seems to disappear when engine warms up. :/
Considering most days have been warm in So. CA, it doesnt repeat often. But sounds like i should have it checked out before the warranty is up.

Good catch 08subiewrx and thanks for the updates.
 
1 - 20 of 565 Posts
Top