Subaru WRX Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So I had to slam on my brakes yesterday to avoid an accident that happened right in front of me and since then I have had some dash lights come on. The TCS light is on the hill assist light is on and the ABS light is on. If I turn the car off and back on they go away but come right back again in less than a block of driving. What is causing this? I made an appointment for it this afternoon to get looked at by the dealership. I don't know if this is something that could be casued from the AP or not so I uninstalled it. After I did that still got the lights back. I am at a loss and dont know what could be causing this. Any one who had this happen or might have an idea feel free to help out at all. ???
 

·
Registered
Joined
·
519 Posts
It might be a wheel speed sensor. Just a stab in the dark if all three lights come on.
 

·
Registered
Joined
·
4,657 Posts
I had this happen when I put my car in gear on jack stands. Like mentioned above, it was a speed sensor issue. I had to clear the code manually or else it would pop up a couple seconds after I turned my car on. I used an AP to clear the codes, but (if you don't have one) try pulling the negative terminal off the battery and stepping on the brake pedal for a minute or so, then re-attach the negative terminal. Not sure if that will clear it or not, but it's worth a try.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
I took it to the dealership to get it looked at and mine is not the first one they have seen this on. They ordered the part and it should be here today. I tried just resetting the ecu with my ap but it just came back. I have only seen it once since I took it in though.. ???
 
1 - 4 of 4 Posts
Top