Subaru WRX Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
I have an 08 2.5i that I've had since about March, and the engine is starting to feel a little sluggish to me. I could just be getting used to it, but it doesn't seem to have the acceleration that it used to have. I don't think its the clutch slipping or anything, but sometimes I think the clutch isn't that great either. One time I was coming up to a red light and it turned green so I put it in 2nd and when I put my foot on the gas it wasn't in gear, but when I clutched out and tried again it did the same thing. It's done similar things a few times.

I feel I've been too hard on it, even though I haven't even driven it 5k miles.

Has anyone else noticed similar things?
 

·
Registered
Joined
·
3,474 Posts
Subaru trademark transmision notchiness. :)
Especially in cold weather.
Basically goes into the shift gate half way. You feel it went in but it didn't really go in all the way.

Happens alot until you get to know the Subie tranny.

And you probably are feeling the speed bug bite you.

Flywheel and/or crank pulley may alleviate the symptoms of response temporarily ;)
 

·
Registered
Joined
·
1,397 Posts
Subaru trademark transmision notchiness. :)
Especially in cold weather.
Basically goes into the shift gate half way. You feel it went in but it didn't really go in all the way.

Happens alot until you get to know the Subie tranny.

Nad you probably are feeling the speed bug bite you.

Flywheel and/or crank pulley may alleviate the symptoms of response temporarily ;)
Oh, so it just wouldn't go into gear? That could be normal.
 
1 - 4 of 4 Posts
Top