Subaru WRX Forums banner

81 - 100 of 122 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter #85
Updated first post, moved previous update here.

2014, July 17 - Modded intake manifold and throttle body so I could rotate the intake manifold.
*Everything is just mach-fitted onto the engine to get charge piping fabricated this weekend, gaskets will go on before final assembly.
Click HERE for more pics (imgur).


















 

·
Registered
Joined
·
2,670 Posts
holy hell! nice man!
 

·
Registered
Joined
·
251 Posts
Discussion Starter #87 (Edited)
Updated first post, moved previous update here.

2014, July 18 - Couple odds n’ ends, mached up everything in the engine bay to get charge pipes fabricated the following day.
*Everything was just mach-fitted onto the engine foir charge pipe fabrication, gaskets will go on before final assembly.


















 

·
Registered
Joined
·
251 Posts
Discussion Starter #92
Updated first post, moved previous update here.


Lots of progress; Finished break-in, went to tuner and decided to install FlexFuel kit that day.


Dyno Info also pasted in first post.

  • Tuner: William Knose, Delicious Tuning
  • Dyno: Mustang AWD, Infamous Performance
  • Weather: 83 Fahrenheit, 44% Humidity, 646ft Elevation
  • o 15 Psi – 367whp, 326wtq - Speed Density
    [*] o 23 Psi – 454whp, 391wtq - Speed Density [S#]




2014, July 27 - Snagged an angle-grinder from Home Depot and fabbed up a throttle body spacer..
OK, NOW it's ready to fire; just need to drain the 91 octane in the tank out and crank in some E85.


















 

·
Registered
Joined
·
251 Posts
Discussion Starter #95
Updated first post, moved previous update here.

2014, Sept 12 - Everything wrapped up and tuned, ran out of fuel at 23 Psi. :(
Pulled trigger on DeliciousTuning FlexFuel kit, dyno numbers at top of first post.

High Boost - 23 Psi on E85


Low Boost - 15 Psi on E85

 

·
Registered
Joined
·
251 Posts
Discussion Starter #97
I have 5k on the built engine, started getting misfires on a cylinder or two around 1k ago, but has gotten progressively worse over the past 1k miles. Now its regularly misfiring on all cylinders. No other codes thrown, just cylinder misfires.

Done so far;
-Compression 10:1 - 154, 155, 158, 155
-Replaced plugs during compression test.
-Sent injectors to DW, just put replacements back in, issue remains.
-Checked spark, coils OK.
-Checked crank sensor, cam sensors.
-Map revisions from tuner (Will Knose).

Symptoms are obviously misfiring, primarily under 3k RPM. Also cannot hit 23 Psi boost target, only get up to 19-20 tops.

Things I've noticed;
-Forge BPV (no longer recirculating as I'm speed density) leaks a little at idle, even with the stiffest springs. Anyone advise of a replacement that would utilize the OEM flange style?

-I noticed the servo motor in throttle body doesn't seem to buzz/humm as consistently as I remember it doing when I first noticed it and questioned WTF it was. But this was after my car sat for 2 weeks on a dead battery and was connected to my other car's battery, while the STi wasn't running yet.
 

·
Super Moderator
Joined
·
1,087 Posts
Nice!
 
  • Like
Reactions: Deek
81 - 100 of 122 Posts
Top