Subaru WRX Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I have a 2010 Subaru Impreza wrx, the car currently has 114000km and when the car is off it’s easy to go into gear, but when I start it it’s hard to go into every gear even, clutch engagement Is all the way at the bottom and the master is flexing a lot with the fire wall plus the brake pedal moves inwards towards the clutch pedal.
I checked the slave no leaks, I bled it with dot 4 brake fluid and the master and replaced the transmission with 75w90 fluid 800km ago but still didn’t help much any ideas, thanks
 

·
Registered
Joined
·
2 Posts
Hi I have a 2010 Subaru Impreza wrx, the car currently has 114000km and when the car is off it’s easy to go into gear, but when I start it it’s hard to go into every gear even, clutch engagement Is all the way at the bottom and the master is flexing a lot with the fire wall plus the brake pedal moves inwards towards the clutch pedal.
I checked the slave no leaks, I bled it with dot 4 brake fluid and the master and replaced the transmission with 75w90 fluid 800km ago but still didn’t help much any ideas, thanks
Hey are you still having this problem, I had this same problem with my 08 WRX with 120,000 on it. What I did was replace my whole clutch hydraulics, my clutch and flywheel with a stage 1, billet fork and pivot ball, and the firewall bolt kit, and guess what, it helped but didn’t fix it. The fix for my car was a loosened pin overtime that connects your clutch rod to the master cylinder. Check your pedal assembly, I also noticed I had a crack.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top