Subaru WRX Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I installed a P&L motorsports intake on my wrx and it now it lags really bad. Also when i started it up the first time it made a weird intake like noise at idle for about 3 secs. whats wrong? help!
 

·
Registered
Joined
·
382 Posts
Is it stuttering?

If so I'd check to make sure you reconnected the MAF wiring.

Other then that its kind of hard to diagnose without more information.
 

·
Registered
Joined
·
3,474 Posts
Make sure all connectors are tightened as well. (assuming the MAF is on properly.) There might be leak if it lags really bad because the MAF reading is off and you are probably running rich if there is a leak between the intake pipe and the inlet hose.

Make sure the MAF is pointing the right direction.
Make sure it is the correct unit. The MAF mounting holes in relation to the plate should be one hole on the top right, the other on the bottm left.

If all is correct and right, also pull the neg of the battery for 45 sec and reconnect to reset the ECU.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
yea everythings right. no leaks, maf is on right it just is really slow and it stutters at high rpms. the p&l website says it requires ecu tuning but will it really run this bad?
 

·
Registered
Joined
·
1,979 Posts
you're definitely in need of tune somewhere along the lines. It's a 73mm diameter MAF housing. This will throw off MAF readings.
Just curious, were you able to get a good deal on this?
 

·
Registered
Joined
·
1,643 Posts
intakes on our cars can cause problems

the weird noise you heard during startup might have been the car warming up or the air pump
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
i bought it used for 140. i took it off today and put the stock system back on and it runs fine. i plan on buying harman motives cai. thanks for the help guys
 

·
Registered
Joined
·
3,474 Posts
yea everythings right. no leaks, maf is on right it just is really slow and it stutters at high rpms. the p&l website says it requires ecu tuning but will it really run this bad?
Bingo! this particular unit was not their standard size but the "big maf" type that is meant really for larger turbines but can be run (with a tune) on a standard size turbine.
So yes, the symptions you are experiencing are "normal" till you get a tune.
Remember that all intakes should get a tune, but if you plan on getting one, that unit you have will probably net more power gains than the standard size Harman unit.
 

·
Registered
Joined
·
57 Posts
go with thE AVI MID RAM INTAKE LOVE IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
3,474 Posts

·
Registered
Joined
·
3,474 Posts
This is why you shouldn't use an intake unless you are tuned or running a map for it.
Kinda harsh dontcha think? especially if it is a mechanical problem as opposed to a tuning problem?
 

·
Registered
Joined
·
3,474 Posts
This is why you shouldn't use an intake unless you are tuned or running a map for it.
My perrin intake works perfectly fine without a tune my WRX ???
With no other parts installed that would alter the AFR, this should be correct.
Glad you are happy with it. Should get you a good amount of power gain also. Just keep the AFR under check once you mod other parts is all. :)
 
1 - 14 of 14 Posts
Top