Subaru WRX Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter #1
Just thought I would contribute something.
My car was playing silly with the clutch, had to take it in for a warranty repair.
I had never taken it past 4500rpm before the first service (5000km's) too, which makes the clutch thing a worry.

Turns out the throw-out bearing (worn) and pressure plate needed to get replaced.

Symptoms: Clutch was feeling notchy early on.. then as it got worse so did the notchiness. After a while you could hear marbles rattling
from under the car (gearbox) although originally I thought the exhaust had gotten loose.

My MY03 was sold with the original clutch and that had gone through hell BUT I know how to shift properly, dont ride the clutch etc (I.E. can drive).

Just thought that may be useful, wonder if anyone got unlucky?

PS the main point is the car feels amazing to me now !! Its like I was missing about [email protected] KW's!! (and comes on sooner)
 

·
Registered
Joined
·
4,657 Posts
glad to hear you got it sorted out. a number of people have complained of clutch problems with the new wrx. I haven't had any issues with my 09, but the 08 clutch was just way too weak for the power imo, and it cooked REALLY easily.
 

·
Registered
Joined
·
417 Posts
Discussion Starter #3
Hey dont tell me the 09's get an upgraded clutch as well!
this just gets better and better... Yeah well I hope the 08 replacement I got was a good one..
 

·
Registered
Joined
·
4,657 Posts
I don't know yet. I haven't felt like I've had to be as careful with the clutch on the 09, so it very well may be upgraded a bit, though that really isn't proof that it's a different clutch. who knows.
 

·
Registered
Joined
·
417 Posts
Discussion Starter #5
Wow well affter driving my car for a day or 2 now, I can honestly say I never experienced my car properly till now. It now pulls hard till redline (compared to the absolutely NO torque above 3000rpm before). I must have just got it buckled from the factory cause it feels better down low too..
Love bogan mods...
 

·
Registered
Joined
·
63 Posts
Glad to hear you got sorted out. Saw you posted in my clutch problem thread as well. I now have about 6,000 miles and my clutch is okay now, though it will still get the occasional "gritty" feel with clutching in and out along with the swoosh sound. When it does occur, the rex drives like ass with a noticeable loss in torque and power compared to when the clutch is working like it should.
 

·
Registered
Joined
·
417 Posts
Discussion Starter #7
Glad to hear you got sorted out. Saw you posted in my clutch problem thread as well. I now have about 6,000 miles and my clutch is okay now, though it will still get the occasional "gritty" feel with clutching in and out along with the swoosh sound. When it does occur, the rex drives like ass with a noticeable loss in torque and power compared to when the clutch is working like it should.
Hey I noticed it being a bit gritty or notchy today as well.. so dissappointed.. I think the clutches are stuffed in these things... I mean its brand new and feel a tad funny - but when I picked it up till yesterday it was brilliant, today its back to being average. The clutch pedal still squeaks when its on the way back up/.... very suspect.. I'll take it back though again if i have to and tell em to up the anti... if i have to ofcourse..
 
1 - 8 of 8 Posts
Top