Subaru WRX Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
502 Posts
Discussion Starter #1
The only information that it blocks is the open door icon.
Its a very nice gauge, and matches the rest of the cluster nicely.
It is NOT mounted on the steering column, its on the cluster surrounding.



 

·
Registered
Joined
·
327 Posts
Looks great. Did it come with that hood that covers part of the top? I would reccomend putting that on there. You did a better job paying attention than I did when I installed mine, b/c mine covers the fuel and temp gauge JUST barely. I mounted mine to the top of the steering column with a screw b/c the sticky tape kept unsticking in the heat.
 

·
Registered
Joined
·
4,657 Posts
That gauge is a really close color match, even in pictures (which usually brings out the color difference). Makes me almost wish I went with prosport instead of STRI, though my STRI is pretty close too. Either way, looks good.

I mounted mine around there to start out with, but ended up with an autometer gauge pod screwed into the steering column on the right side. I think it turned out really well and it allowed me to get it out of the way of the gauge cluster. It only partially obscures the 140mph+ portion of the speedo and only from my right eye, so visibility is about perfect, though I have it mounted as close as it can be to the wiper control arm without restricting it's movement in any way.

Also, good looking Avic D3. I really love that head-unit, I have one too. I would have thought it was OEM in those pics had I not known better.
 

·
Registered
Joined
·
502 Posts
Discussion Starter #4
I was going to mount it on the steering column but it blocked too much to my liking, so I found that mounting on the cluster was best. Also the wires are hidden because it runs under the cluster. Very happy with the setup.

For the price of $80, well worth it!!
 

·
Super Moderator
Joined
·
2,745 Posts
I just got mine installed a couple minutes ago and I have a couple questions...

I'm putting it above the cluster to the right, What did you use to mount it? The tape they gave me sucked and I tried some other 3m double sided with the same problem...

It sticks about a second then the gauge just a somersault, and that's not even driving...

I don't want to drill into my dash, any suggestions?

Also readings wise, are you getting 15-20 vaccume while idling, near 0 when normal take off and pushing into the teens when WOT?

~Mike
 

·
Registered
Joined
·
327 Posts
Also readings wise, are you getting 15-20 vaccume while idling, near 0 when normal take off and pushing into the teens when WOT?
~Mike
I gave up on tape as as soon as it got hot, it would fall off. I always have gotten 20 mmhg when idling and then normal/soft acceleration right around 0 then I don't pay enough attention on WOT. Usually though right around 12-13 psi of boost. What I love about the gauge is if you keep it under boost you can get decent mileage!
 

·
Registered
Joined
·
502 Posts
Discussion Starter #8
I did not clean mine at all, and i bet there is alot of oil from my hand. I just used the double sided take that it came with and its really stuck on there, the gauge does not move at all even in hot weather. I really love the location that i install it , it doesnt block anything.
 

·
Registered
Joined
·
88 Posts
a pillar mounted my blue prosport electronic gauge. love it. stock tune you shouldnt hit more then 13psi wot. if you are, you have a problem, fix it...quick!
 

·
Registered
Joined
·
574 Posts
I installed mine in the cluster, off to the right (see avatar, I'll look for the bigger picture)

I have some 3M industrial velcro. It sticks very well, doesnt move, and is adjustable since it's velcro. The only thing it blocks at all is anything in the spedo above 120mph+. If I'm going that fast, I need to be looking at the road, not the gauges...

SJ
 

·
Registered
Joined
·
1,582 Posts
im too impatient!! haha. i just bought mine for $62 after shipping. cant wait for it to get here!!!! ;D anyone know if theres any way to replace the needle with a white one? that would make it perfect.
 

·
Registered
Joined
·
327 Posts
im too impatient!! haha. i just bought mine for after shipping. cant wait for it to get here!!!! ;D anyone know if theres any way to replace the needle with a white one? that would make it perfect.
You want amber with white needle? I know that with mine I can switch between all white numbers w/white needle and amber. I'm not sure if you can change just the needle.
 

·
Registered
Joined
·
1,582 Posts
i found a 45mm that matches our gauges perfect the day after i bought the prosport. haha. oh well. Ill see how the prosport does. The other was like 110, i got mine for 60 shipped. I dont remember what brand it was. Big Sky is planning on buying it (its in his intro thread)
 

·
Registered
Joined
·
3,790 Posts
Nice install! My Prosport gauges are way too dim in my Accord...just wondering if you have the same problem in the daytime?
 
1 - 16 of 16 Posts
Top