Subaru WRX Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
Hey,

I just went to install my new Stealth Turn Signal Bulbs from Stealth Auto (stealthbulbs.com) and when I pulled out one of the front turn signal/side marker bulbs, it was 1157NA and not 3457 as Sylvania lists it when I use their lamp replacement guide. I am going to try to replace the rear turn signal bulbs now and see if they were correct or not regarding those.

DAMNIT, I bought two pairs of those, $60 down the drain. :mad: :(

Thanks,
MrElussive
 

·
Registered
Joined
·
223 Posts
Discussion Starter #2
I installed the Stealth Auto 7440 rear turn signals and they look great, no more yellow in the tail lights. When they are illuminated, they are noticeably not as bright as the factory yellow bulbs but they should still be visible enough even on the sunniest days. I purchased two pairs of Sylvania Silverstar 1157 bulbs for the front turn signals and dropped those puppies in also. They are clear and a bit amberish and like rainbowy colored, I don't know to explain it. When these 1157 front turn signal bulbs are on, they are factory amber color and 100% as bright as stock bulbs. Should I post some pictures for you pimps???
 

·
Registered
Joined
·
1,362 Posts
dude, resize your pics, they are way too big
 

·
Registered
Joined
·
1,843 Posts
the error about the signal bulb is in the owner manual of the car... so its not sylvania`s fault
you should have read my GUIDE on the sticky of the unique style board... i wrote all the bulb number there many months ago...

http://www.3gwrx.com/forum/index.php?topic=584.0
 

·
Registered
Joined
·
1,362 Posts
What are you, the forum police? Seriously though, done and done.
Not at all, its just a pain to scroll all the way down to move the bar over and hope you didnt scroll to much or to little.

Thanks for fixing them though, your lights look nice, sick dog too.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #9
MrPrimus, I hope you you know that I was making a joke about the forum police comment, that's why I started the next sentence with "Seriously though,..." Anyways, I have no idea why the pictures came out so god damn dark because I took these pictures in the garage with all of the lights on where in person the room is lit up just like any other room. The camera's flash was working on every picture but the camera decided to automatically adjust the lighting to MAXIMUM DARKNESS. :mad:

I'm probably going to get a new camera today and I'll take some more pictures.
 
1 - 10 of 10 Posts
Top